`

Color Me Less--poj--1046

 
阅读更多

Color Me Less

Time Limit: 1000MS

Memory Limit: 10000K

Total Submissions: 18730

Accepted: 8886

Description

A color reduction is a mapping from a set of discrete colors to a smaller one. The solution to this problem requires that you perform just such a mapping in a standard twenty-four bit RGB color space. The input consists of a target set of sixteen RGB color values, and a collection of arbitrary RGB colors to be mapped to their closest color in the target set. For our purposes, an RGB color is defined as an ordered triple (R,G,B) where each value of the triple is an integer from 0 to 255. The distance between two colors is defined as the Euclidean distance between two three-dimensional points. That is, given two colors (R1,G1,B1) and (R2,G2,B2), their distance D is given by the equation

Input

The input is a list of RGB colors, one color per line, specified as three integers from 0 to 255 delimited by a single space. The first sixteen colors form the target set of colors to which the remaining colors will be mapped. The input is terminated by a line containing three -1 values.

Output

For each color to be mapped, output the color and its nearest color from the target set.

If there are more than one color with the same smallest distance, please output the color given first in the color set.

Sample Input

0 0 0

255 255 255

0 0 1

1 1 1

128 0 0

0 128 0

128 128 0

0 0 128

126 168 9

35 86 34

133 41 193

128 0 128

0 128 128

128 128 128

255 0 0

0 1 0

0 0 0

255 255 255

253 254 255

77 79 134

81 218 0

-1 -1 -1

Sample Output

(0,0,0) maps to (0,0,0)

(255,255,255) maps to (255,255,255)

(253,254,255) maps to (255,255,255)

(77,79,134) maps to (128,128,128)

(81,218,0) maps to (126,168,9)

Source

Greater New York 2001

先读懂题意:

很简单,就是给定一个三维点以及一个由16个三维点组成的点集,求这个给定三维点与点集中哪个三维坐标点的距离最小。

基本思路:

就是模拟题啦,照着题意做就行。

代码如下:

#include <iostream>

#include <cmath>

int R[16], G[16], B[16];

void mapping(int r, int g ,int b)

{

long diff;

int flag;

int min = 255*3 + 1;

for(int i=0; i<16; i++)

{

//diff = abs(r-R[i])+abs(g-G[i])+abs(b-B[i]); WA??

//这里很诡异,我简化成求绝对值的和,提交后居然是WA,实在搞不懂

//非得要我求平方和之后再开方??

diff = sqrt((double)(r-R[i])*(r-R[i]) + (double)(g-G[i])*(g-G[i]) + (double)(b-B[i])*(b-B[i]));

if(diff < min)

{

min = diff;

flag = i;

}

}

std::cout<<"("<<r<<","<<g<<","<<b<<") maps to "

<<"("<<R[flag]<<","<<G[flag]<<","<<B[flag]<<")"<<std::endl;

}

int main()

{

int r, g, b;

for(int i=0; i<16; i++)

{

std::cin>>R[i]>>G[i]>>B[i];

}

std::cin>>r>>g>>b;

while(r!=-1 || g!=-1 || b!=-1)

{

mapping(r, g, b);

std::cin>>r>>g>>b;

}

system("pause");

return 0;

}

分享到:
评论

相关推荐

Global site tag (gtag.js) - Google Analytics